PKGBUILDs/cs-dev-sshkeys/PKGBUILD

31 lines
1.2 KiB
Bash

# Maintainer: Markus Pesch <markus.pesch@cryptic.systems>
pkgname=cs-dev-sshkeys
pkgver=0.2.1
pkgrel=2
pkgdesc='Register development ssh keys in /root/.ssh/authorized_keys'
arch=('x86_64' 'armv7h')
url=https://git.cryptic.systems/volker.raschek/set-sshkeys
license=('Apache 2.0')
depends=('openssh')
install=${pkgname}.install
makedepends=('git' 'go' 'make')
source=(
"https://git.cryptic.systems/volker.raschek/set-sshkeys/archive/v${pkgver}.tar.gz"
"local://authorized_keys"
)
sha512sums=('8f3522bbe4fc5e7b163a675f5d3831aa655c2fff88074f35a2b4e539e808a63cf8ef24cc5a2981caaeb16776f62f16475bb33d68b0ef81e158b1391382842ec9'
'0bf0988aceb60ca9b4bbc26403258250d1d83208169216ee3f761809f2c5bd23a6a303bb1ebffc0198d4887b6fc91dadb44a1beb86bb26c2bfe0747f20927e3c')
build() {
GOBIN=${HOME}/go/bin
PATH=${GOBIN}:${PATH}
make --directory ${srcdir}/set-sshkeys bin/tmp/set-sshkeys VERSION=${pkgver}
}
package() {
install -D --mode 644 ${srcdir}/authorized_keys ${pkgdir}/etc/set-sshkeys/authorized_keys
install -D --mode 4755 ${srcdir}/set-sshkeys/bin/tmp/set-sshkeys ${pkgdir}/usr/bin/set-sshkeys
install -D --mode 644 ${srcdir}/set-sshkeys/LICENSE ${pkgdir}/usr/share/licenses/set-sshkeys/LICENSE
}